Rails 2.2.2 로 개발하던 것을 2.3.2 로 바꿀때.

environment.rb 에서 RAILS_GEM_VERSION 을 ‘2.2.2’로 개발중이던것을
‘2.3.2’로 수정하면..
uninitialized constant ApplicationController
라는 Error Message가 뜹니다.
Rails가 2.3 으로 Update 하면서 application.rb 가 application_controller.rb 로 변경이 되어서 생기는 문제점입니다.
직접 application.rb 파일을 rename 해주거나.
rake rails:update:application_controller
이런식으로 rake를 해주셔도 됩니다.
저는 rake를 사용해서 작업했습니다.
이제 잘 되네요🙂
관련링크
덧.
위에 적은 rake는 rake rails:update에 포함되어 있다고 하네요.

답글 남기기

아래 항목을 채우거나 오른쪽 아이콘 중 하나를 클릭하여 로그 인 하세요:

WordPress.com 로고

WordPress.com의 계정을 사용하여 댓글을 남깁니다. 로그아웃 / 변경 )

Twitter 사진

Twitter의 계정을 사용하여 댓글을 남깁니다. 로그아웃 / 변경 )

Facebook 사진

Facebook의 계정을 사용하여 댓글을 남깁니다. 로그아웃 / 변경 )

Google+ photo

Google+의 계정을 사용하여 댓글을 남깁니다. 로그아웃 / 변경 )

%s에 연결하는 중